Architect

Bidding

For the Owner, there will not be anything in this category requiring your action.

Billing

View Billing

From the main dashboard select Billing > Select the Project Name > View/Sign.

Owner BIll

Approve/Print

Click the Approve button > I Agree to electronically sign the bill and return to the General Contractor. Click Print button to open PDF for print/download.

Change Orders

View Change Orders

From the main dashboard select Change Orders > Select the Project Name.

Sign Change Orders

Change Orders > Select Project Name > Sign C.O. > I Agree > OK > Close Window

Contracts

View/SignPrint Your Contract

From the main dashboard select Contracts > Select the Project Name. Select View/Sign Contract. This will launch a new window that contains and electronic version of the contract. Click Digitally Sign this Contract > I Agree > OK > Close Window > Create PDF for Print to download to your computer or print.

Daily Log

View a Daily Log

From the main dashboard select Daily Log > Select the Project Name> Click on Date to open PDF of Daily Log.

Lien Releases

View Lien Releases

Lien Releases will be available for both signed Owner Pay Applications as well as Subcontractor Line Releases. To view click Lien Releases > Select Project>View Lien

View Lien Releases

Meetings

View Meeting Minutes

Meetings > Select Project > click Title to open PDF of the Meeting Minutes

Meeting List

Send Correspondence

Click Send Email > Select General Contractor Recipient > Select Recipients > Enter Message > Send Correspondence.

Send Email

Messages

View / Print Messages

To view messages, go to Messages > Select Project. This will bring you to your list of messages. They will appear with the last message received at the top of the list. You have the ability to search messages by Subject or Filter by Contacts.

Message List

Click on the blue hyperlink to open the message. You will see the message and a blue hyperlink for any attachments to the message. Click on the blue hyperlink to open the PDF of the attachment to view/print. To be taken directly to the document, click on View the "document" in Filing Cabinet Link.

Planroom

View / Print Drawings

To view drawings, click on Plan Room > Select Project > Drawings. This will show you all of the drawing categories. Click on each Drawing Category to reveal the list of drawings. Click on the piece of paper to open the PDF of the drawing, hover print and download icons to save to your computer or print.

View / Print Specifications

To view Specifications, click on Plan Room > Select Project > Specifications. This will show you all of the specification categories. Click on the piece of paper icon to open the PDF of the specification section, hover print and download icons to save to your computer or print.

View/Print Addenda

To view Addenda, click on Plan Room > Select Project > Addenda. This will show you all of the Addenda. Click on the piece of paper icon to open the PDF of the Addenda, hover print and download icons to save to your computer or print.

View/Print Photos

To view Photos, click on Plan Room > Select Project > Photos. This will show you thumbnail images of all photos. Check the box for the photos > download

Punch List

View Punclist Items

To view Punch List Items click Punch List > Select Project. Your punch list items will appear on the list. You can filter by All, Open, Closed. If photos are attached there will be a blue hyperlink for the photo to click on to open the image.

Required Documents

There will not be any Action Items for the Owner regarding Required Document for the proejct.

RFI

Create New RFI

To create an RFI click RFI>Select Project > Create New RFI

Create New RFI

Submit RFI

To submit the RFI fill in the information on the RFI worksheet > Add message to text box > Add any Attachments > Submit

Submit an RFI

Respond to RFI

To Repond to the RFI click on the Subject to open the RFI form to complete.

Open RFI Form

Complete the form by entering your answer to the RFI in the Comments box, then click Answer at the top of the form to submit to GC your response.

Enter Text & Answer/Submit RFI to GC

To print, click RFI > Select Project > Print

RFPs

View RFP's

To view RFP's click on the RFP icon.

Click RFP Icon

Click on the Approve/Reject hyperlink to open the RFP for review.

Click Approve/Reject Hyperlink

Approve RFP's

On the RFP, click on the Pending dropdown to either Approve or Reject the pricing for the RFP.

Hover Pending to make Status Selection

To submit the response back to the GC, click the Submit Response button at the top of the screen.

Schedules

View Schedules

To view schedules click on Schedules > Select project > click on the piece of paper icon to open the PDF of the schedule.

Once the schedule is open in PDF, hover over the print or download icons to save or print the schedule.

Send Email

Click Envelope icon > Select Recipient > Enter message in text box > upload attachment if desired > Send

Submittals

View Submittals

To view Submittals click on Submittals > Select Project, scroll to list listed items to find Submittal Items requiring your approval. You will only see Submittal Packages with items requiring your action. Then click the blue Pending link to open the Submittal item worksheet. To view any attachments the General Contractor has loaded for you to view click on the blue hyperlink with the title of the document listed.

ClicClick Submittals

Approve Submittals

To approve Submittal click on the Pending hyperlink to open the Submittal form to complete.

Click Pending

Complete the form by clicking on the drop down selections for First Status. Choose from the options on the list to approve or reject the Submittal. Then click the "Choose File" button to browse your computer's hard drive to find your approved PDF of the submittal package to upload>Click Choose>Submit to GC.

Update First Approval Required By:

Warranties

To veiw Warranties, click Warranties>Select Project>View Owner A hyperlink to open the PDF from the GC.

Click View Owner A

Phase Bidding

Click on Phase Bidding>Select Project>Approve/Reject to open up the Phase to review.

Click Phase Bidding

Click the Pending drop down menu to select whether to Approve or Reject the Phase Pricing. Then click Submit to GC to send your response.

Purchase Orders

There will not be any action items for Owners regarding Purchase Orders for the project.

Misc. Documents

View Misc. Documents

To view Misc. Documents that have been uploaded by the General Contractor, click Misc. Documents > Select Project > View

Example of Viewing Misc. Documents

Send a Correspondence with Regards to a Misc. Document

If you would like to send correspondence about the uploaded Misc. Document, you can click on the Send Email > Select the recipient for the General Contractor employee you wish to communicate with > Enter message > Send Correspondence.

Add a Misc. Document

To Add a Misc. Document click the green button to Add Miscellaneous Document > Add Description > Choose File from computer > Save

Safety Reports

View Safety Reports

To view the Safety Reports click Safety Reports > Choose Project > View

Example of Viewing Safety Reports

Send a Correspondence About a Safety Report

If you would like to send correspondence about the uploaded Safety Report, you can click on the Send Email Button > Select the recipient for the General Contractor employee you wish to communicate with > Enter message > Send Correspondence.