Subcontractor

Last updated 4 months ago

Bidding

Respond to an Invitation to Bid

As a subcontractor you will receive your Invitation to Bid via an e-mail from the General Contractor. Inside of that e-mail contains a link to the bidding portal. There you can mark your intent to bid, download and view addenda, drawings, specifications, & photos. You will also be able to view your bid items and submit your bid to the GC.

Subcontractor Global Dashboard

View your Quote

After you've submitted your quote, from the main navigation select Bidding > Select the Project Name you would like to view and you will be taken to the Sub Quote screen. From here you can view or print your quote. To print, select Printable Version Of This Bid and a window will open with a .pdf where you can save your quote to your hard drive or print it.

Example of Viewing Your Sub Quote

Billing

View Billing

From the main dashboard select Billing > Select the Project Name.

Submit Schedule of Values

From the main dashboard select Billing > Select the Project Name. If you have not submitted a schedule of values you will be asked to do so. Select Click Here.

Submit Schedule of Values

Add your schedule of payments below by pressing the "Add New Line" button below. When you have finished adding enough lines to utilize all of your contract amount, press the "Submit Schedule For Approval" button above. Your schedule will be reviewed and approved or rejected. You will be notified when the General Contractor has approved/rejected your schedule.

Add New Bill

Billing > Select the Project Name>Add Bill

Add New Bill

Enter Invoice Number and Date Range for current billing period.

Invoice Number/Date Range Entry

Enter values for all line items billing against this pay period>Preview New Bill

Enter Bill Value/Preview New Bill

After previewing New Bill>Submit

Once the bill has been submitted you will be prompted to sign the Lien Release. Click Sign Lien Release>I Agree>OK>Close Window

Change Orders

View Change Orders

From the main dashboard select Change Orders > Select the Project Name.

Sign Change Orders

Change Orders>Select Project Name>Sign C.O.>I Agree>OK>Close Window

Contracts

View Your Contract

From the main dashboard select Contracts > Select the Project Name. Select View Final. This will launch a new window that contains a .pdf version of the signed contract.

Sign Your Contract

Contracts>Select Project Name>View/Sign>I Agree>OK>Close Window

Sign Subcontract

Daily Log

View a Daily Log

From the main dashboard select Daily Log > Select the Project Name> Click on Date to open PDF of Daily Log.

Lien Releases

View Lien Releases

Lien Releases>Select Project>View Lien

Sign a Lien Release

Lien Releases>Select Project>Sign Lien

Meetings

View Meeting Minutes

Meetings>Select Project>click Title to open PDF of the Meeting Minutes

Meeting List

Send Correspondence

Click Send Email>Select General Contractor Recipient>Select Recipients>Enter Message>Send Correspondence.

Send Email

Messages

View/Print Messages

To view messages, go to Messages>Select Project. This will bring you to your list of messages. They will appear with the last message received at the top of the list. You have the ability to search messages by Subject or Filter by Contacts.

Message List

Click on the blue hyperlink to open the message. You will see the message and a blue hyperlink for any attachments to the message. Click on the blue hyperlink to open the PDF of the attachment to view/print. To be taken directly to the document, click on View the "document" in Filing Cabinet Link.

Planroom

View/Print Drawings

To view drawings, click on Plan Room>Select Project>Drawings. This will show you all of the drawing categories. Click on each Drawing Category to reveal the list of drawings. Click on the piece of paper to open the PDF of the drawing, hover print and download icons to save to your computer or print.

View/Print Specifications

To view Specifications, click on Plan Room>Select Project>Specifications. This will show you all of the specification categories. Click on the piece of paper icon to open the PDF of the specification section, hover print and download icons to save to your computer or print.

View/Print Addenda

To view Addenda, click on Plan Room>Select Project>Addenda. This will show you all of the Addenda. Click on the piece of paper icon to open the PDF of the Addenda, hover print and download icons to save to your computer or print.

View/Print Photos

To view Photos, click on Plan Room>Select Project>Photos. This will show you thumbnail images of all photos. Check the box for the photos>download

Punch List

View Punclist Items

To view Punch List Items click Punch List>Select Project. Your punch list items will appear on the list. You can filter by All, Open, Closed. If photos are attached there will be a blue hyperlink for the photo to click on to open the image.

Required Documents

View Required Documents

To view Required Documents click on Required Documents>Select Project>View. The document will open as a PDF which you will fill out and sign as required by your General Contractor.

Upload Required Documents

To upload your signed Required Document into PASKR once completed, click green button Import & Send>Choose File>Add message>Send Email

RFI

Create New RFI

To create an RFI click RFI>Select Project>Create New RFI

Create New RFI

Submit RFI

To submit the RFI fill in the information on the RFI worksheet>Add message to text box>Add any Attachments>Submit

To print, click RFI>Select Project>Print

RFPs

View RFP's

To view RFP's you have been invited to price, click RFP's>Select Project>View Price

Submit RFP

To submit your RFP, enter your RFP price, # of Days in additions to the schedule, and any comments regarding Inclusions/Exclusions/Additional comments about your quote>then click the green button Submit Price.

To print a copy of your RFP, from the RFP list, click View to open the PDF. Hover over the download or print icons to save to your computer or print.

Schedules

View Schedules

To view schedules click on Schedules>Select project>click on the piece of paper icon to open the PDF of the schedule.

Once the schedule is open in PDF, hover over the print or download icons to save or print the schedule.

Send Email

Click Envelope icon>Select Recipient >Enter message in text box>upload attachment if desired>Sen

Submittals

View Submittals

To view Submittals click on Submittals>Select Project, scroll to list listed items in your Division. You will only see Submittal Packages with items requiring your action. Then click the blue Pending link to open the Submittal item worksheet. To view any attachments the General Contractor has loaded for you to view click on the blue hyperlink with the title of the document listed.

Submittal List

Upload and Submit Submittals

To upload your Submittals for review by the General Contractor, click on Submittals>Select Project>Click on the blue Pending hyperlink to open worksheet>Choose File to select the PDF from your computer's hard-drive>Save>Submit to GC

Submittal Worksheet to Upload Submittal

To print the Submittals Schedule, Submittals Log, or Transmittals, click on the blue hyperlinks to open the PDF's>hover the download or print icons to save or print.

Warranties

Sign Warranty Letter

To sign your warranty letter, after you have submitted your final retainage bill, go to Warranties>View/Sign Owner A>Sign Owner A Warranty Letter>I Agree>OK>Close Window>Create PDF for print if desired.

Warranty Letter List

Sign Owner A Warranty Letter>I Agree>OK>Close Window>Create PDF for print if desired.

Phase Bidding

View Phase Bidding List

Click Phase Bidding>Select Project View/Price

Phase Bidding List

Submit Phase Pricing Quote

Enter Bid Amount>Enter # of days to complete>Note any Exclusions or Additional comments>Submit Pricing.

Purchase Orders

Sign PO's

Vendors will click on Purchase Orders>Select Project. Click on the Sign P.O. button>I agree>Close Window

Purchase Order Screen

Sign PO Lien Release

Vendors will need to sign their PO Lien Release prior to final payment being issued by the General Contractor. Click on Sign Lien>I Agree>OK>Close Window

Creating a PDF for Print

Click View/Print to open the PDF to view. Hover the lower portion of the screen to reveal the download or print options.

Send Correspondence regarding the Purchase Order

Click Send Email>Select Recipient from GC company>Select these recipients>Enter message in text box>upload attachment if desired>Send Correspondence

Misc. Documents

View Misc. Documents

To view Misc. Documents that have been uploaded by the General Contractor, click Misc. Documents > Select Project > View

Example of Viewing Misc. Documents

Send a Correspondence with Regards to a Misc. Document

If you would like to send correspondence about the uploaded Misc. Document, you can click on the Send Email > Select the recipient for the General Contractor employee you wish to communicate with > Enter message > Send Correspondence.

Add a Misc. Document

To Add a Misc. Document click the green button to Add Miscellaneous Document > Add Description > Choose File from computer > Save

Safety Reports

View Safety Reports

To view the Safety Reports click Safety Reports > Choose Project>View

Example of Viewing Safety Reports

Send a Correspondence About a Safety Report

If you would like to send correspondence about the uploaded Safety Report, you can click on the Send Email Button > Select the recipient for the General Contractor employee you wish to communicate with > Enter message>Send Correspondence.